Simon Strandgaard <neoneye / adslhome.dk> wrote:
[snip] 
> Your 'of' is a mix between times and map. Wouldn't it be better to
> name it 'times_map' ?
> 

Even simpler.. it would make sense to me if it were just named 'maps'

  a, b, c = 3.maps {|n| -n}
  # a=0, b=-1, c=-2

--
Simon Strandgaard