Ara.T.Howard wrote:
> RCR - Numeric#of - an accumlative version of Numeric#times
> [...] 
> them = 3.of{ Array.new }

It also looks awfully terse. How about:

   them = 3.times_collect{ Array.new }

I think it reads better. "Three times, collect [result of] Array.new".

It is three characters longer than the (seemingly) equivalent:

   Array.new(3){Array.new}

but far more readable, and could assume another top-level container.

Just my 0.02 NOK.

-- 
(\[ Kent Dahl ]/)_    _~_    _____[ http://www.pvv.org/~kentda/ ]_____/~
  ))\_student_/((  \__d L b__/     Master of Science in Technology     )
( \__\_?|?_/__/ ) _)  Industrial economics and technology management (
  \____/_?_\____/ (____engineering.discipline_=_Computer::Technology___)