Hal Fulton wrote:

> Here's a small puzzle.
>
> I take a working .rbx and I do a require 'yaml' near the top.
>
> Now it fails.

I can't explain exactly why this is happening, but I'm removing the 
require 'date' at the top of lib/yaml/rubytypes.rb.  This module is 
conditionally loaded in ext/syck/rubyext.c now.  For now, you should be 
able to remove the line and -- though  it's hard to say without really 
looking into auto-reload.rb -- you should be okay.

_why