原です。

>正木です。

>|gcdはインタフェース、bitsize, isqrt, irootは名前の点で引っか
>|かってます。
>
>Math.gcd(a, b) というのは、a, b が整数に限られるということを考え
>ると、現在の Float 中心の Math にはなじまない気がします。
>Integer.gcd(a, b) でも良いですが、Integer#gcd でまづいという理由が
>良く分かりません。

私も Integer#gcd でいいと思いますが、ちょっと迷うのは拡張して 3
つ以上数の GCD を作った場合ですね。a.gcd(b, c, d) とか、array
で出てきた時 array[0].gcd(*array[1..-1]) と書くのがちょっと汚い
かな、と。まあ、それでもいい気もしますけど。