けいじゅ@日本ラショナルソフトウェアです.

In [ruby-math :00580 ] the message: "[ruby-math:00580] Re: int / int -
> ? ", on Aug/21 12:04(JST) Shin-ichiro HARA writes:

>原です。

>> > >#どさくさ紛れの要望ですが、Rational(1, 2).inspect は 
>> > >#"Rational(1, 2)" じゃなくて "1/2" にしません?
>> > うーん. (1/2) とカッコ付きなら問題ないかな、複素数は(1+2i)とかかな.

>>それってto_sとほとんど同じになるような。
>私は同じでいいと思うんですよ。
>
>p [1/2, 3/4, 5/6]
>
>の出力が
>
>[Rational(1, 2), Rational(3, 4), Rational(5, 6)]
>
>だったりしたら、あまりにうるさいと思いません?
>
>[1/2, 3/4, 5/6]
>
>で十分でしょう。

pの意味をちょっと取り違えていません? pって一応開発用だからなぁ... あんま
り省略するのも何かと思わなくもないんですが... ``/''がついていれば、
Rationalってわかるからいいのかな...

でも, どちらにしてもかっこは必要だと思いますけどね.

inspectの出力結果に関しての指針って特にないですよね? 

__
..............................石塚 圭樹@日本ラショナルソフトウェア...
----------------------------------->> e-mail: keiju / rational.com <<---