原です。

>In <200108201558.AAA06630 / cupmail0.rational.com>
>On Tue, 21 Aug 2001 00:58:47 +0900
>keiju / ishitsuka.com (石塚圭樹) wrote:
> > >#どさくさ紛れの要望ですが、Rational(1, 2).inspect は 
> > >#"Rational(1, 2)" じゃなくて "1/2" にしません?
> > うーん. (1/2) とカッコ付きなら問題ないかな、複素数は(1+2i)とかかな.
>
>それってto_sとほとんど同じになるような。

私は同じでいいと思うんですよ。

p [1/2, 3/4, 5/6]

の出力が

[Rational(1, 2), Rational(3, 4), Rational(5, 6)]

だったりしたら、あまりにうるさいと思いません?

[1/2, 3/4, 5/6]

で十分でしょう。