けいじゅ@日本ラショナルソフトウェアです.

In [ruby-math :00467 ] the message: "[ruby-math:00467] Re: NArray#== ", on Jun/25 13:26(JST) 
masa / stars.gsfc.nasa.gov writes: 
>>From: rubikitch <rubikitch / ruby-lang.org>
>>Subject: [ruby-math:00465] Re: NArray#==
>
>> 現仕様である要素ごとの比較を行う NArray#== は別の名前にして、
>> 配列としての等しさを比較するメソッドをNArray#== にすべきだと
>> 感じました。やはり == は true か false を返すという暗黙の了解
>> みたいなものがあると思いますが、どうでしょう?
>
>うーむ、そうですか。要素同士の比較結果を配列で返す、という現状の
>仕様は、私は結構重要なポイントだと思っているので、できれば変えた
>くないと思っています。Octaveでもそういう仕様になってます。

ここはRubyの世界なんだからRubyでどうなっているかに従うべきでしょう. ==の
ような基本的なメソッドの意味を変えるのは問題ありです. 

__
..............................石塚 圭樹@日本ラショナルソフトウェア...
----------------------------------->> e-mail: keiju / rational.com <<---