青山です。

On Wed, 14 Jun 2000 01:15:14 +0900,
"Shigeo Kobayashi" <shigeo / tinyforest.gr.jp> wrote:

>   round_up(1.475) == ceil(1.475) == 2
>   round_down(1.475) == floor(1.475) == 1
>   round_up(-1.475) == floorl(-1.475) == -2
>   round_down(-1.475) == ceil(-1.475) == -1
> で、round_up も round_down も ceil と floor でカバーできる
> ので、round_up と round_down は余計かなと考えたのです
> が、どうでしょう?

あ、なるほど。というか、これって、正負によって、利用者が使い分けろって
事でしょうか?

if 0 < n
  n.floor
else
  n.ceil
end

それはちょっと不便だと思います。内部処理では、という事なら別ですが。

> C に合わせれば、C プログラマーには親切かもしれませんが
> 「互換性」と天秤にかけた場合どうでしょう?
> それと、[ruby-math:00302] の「整数を返すという伝統」という
> のがちょっと気になります(伝統というのが何なのかはわかり
> ませんが、私は「互換性」をとりたい気がします。)。

「互換性」というと、引数無しの場合は Integer という事でしょうか?
私としては、ceil, floor は現在のままでも良いかとも思っています。

要は、小数点を中心とした、(Excel などで標準の)まるめの機能が欲しいとい
うだけですから。そして、この機能は有効桁数を中心とする BigFloat とは相
反するものですし、電卓や Excel でもなじみのある動きでもあるので、Float
に入れるのが良いかな、という感じです。


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>