児玉 です. 度々すみません.

Daisuke IKEGAMI <daisu-ik / is.aist-nara.ac.jp> さんの
ruby 1.4.4 (2000-04-14) [alpha-osf4.0f] と
Polynomial の問題で...

From: "K.Kodama" <kdm / kobe-kosen.ac.jp>
Subject: [ruby-math:00255] Re: Polynomial.rb and floating point exception
Date: Mon, 17 Apr 2000 08:50:37 +0900
Message-ID: <20000417085037Y.kdm / kobe-kosen.ac.jp>
....
> i686-linux の Ruby1.4.3 では状況が再現できていません.
> 1.4.4 にいれかえて試験しようと思いますが,
> 新年度の仕事が忙しいので, ちょっとまって下さい.
....
  と書きましたが, 昼休みに 1.4.4 を入れてみました.
Alpha は無いので Celeron/Linux マシン.
./configure --enable-shared
でコンパイル, インスト−ル後, ldconfig しました. 問題無し.
本体の ruby-list の方で聞く?

$ ldd `which ruby`
        libruby.so.1.4 => /usr/local/lib/libruby.so.1.4 (0x4000a000)
        libdl.so.1 => /lib/libdl.so.1 (0x4009f000)
        libm.so.5 => /lib/libm.so.5 (0x400a2000)
        libc.so.5 => /lib/libc.so.5 (0x400ab000)
$ ruby -vd -e 'require "polynomial"'
ruby 1.4.4 (2000-04-14) [i686-linux-libc1]
....略

-- 
K.Kodama(kodama / kobe-kosen.ac.jp)