ruby-mathのみなさん、こんにちは。
2月頃からメールがながれていないようですが、
もしかして議論の場が移りましたか?

私は、zsh 3.0.4の上で、ruby 1.4.3, ruby 1.4.4 を動かしてます。

ruby -e 'require "polynomial"'
とすると、
zsh: floating point exception ruby
となり、$statusは136が入ってます。

これはどうしたらよいでしょうか。

使っている計算機は、ALPHA station 255(300MHz)です。
ruby --version の返り値は、
ruby 1.4.4 (2000-04-14) [alpha-osf4.0f]
で、configureに--enable-sharedをつけてmakeしました。
make testもsucceededでしたし、
普通にrubyをつかう分には、エラーはでないようです。

ruby -dも試してみましたが、ruby -d -e 'require "polynomial"'の結果は、
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:343: warning: discarding old **
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:380: warning: discarding old sqrt
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:392: warning: discarding old exp
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:408: warning: discarding old cos
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:417: warning: discarding old sin
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:426: warning: discarding old tan
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:434: warning: discarding old log
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:443: warning: discarding old log10
/home/is/daisu-ik/lib/ruby/1.4/complex.rb:451: warning: discarding old atan2
zsh: floating point exception ruby -d -e require "polynomial"
です。うーん。

どうしたらいいか、教えて下さい。よろしくおねがいします。
--
池上 大介
Daisuke IKEGAMI <daisu-ik / is.aist-nara.ac.jp>
奈良先端科学技術大学院大学 情報科学研究科
情報処理学専攻 情報基礎学講座 関研究室