ruby/jed のために最近は --enable-shared で libruby.so
を作ってるんですが、rubyのversion upすると

jed: error in loading shared libraries
/usr/local/lib/ruby/i586-linux/libruby.so: undefined symbol: stat

とか言われてしまいます。jedをmakeしなおすと動くんだけど。
こういうと libruby.so のさしかえだけですむと思ってたのは
甘かったのでしょうか?

-- 
人生を背負い投げ

菊谷 誠(Kikutani Makoto)  kikutani / sprintmail.com
                          kikutani / debian.or.jp (Linux関係のみ)