けいじゅ@日本ラショナルソフトウェアです.

メイルが幾つか腐っていた...

In [ruby-list :9191 ] the message: "[ruby-list:9191] Re: [Q] fail and
exit in rescue SystemExit ", on Aug/18 13:18(JST) Yukihiro Matsumoto
writes:

>まつもと ゆきひろです

>failを再定義することが即ち問題であるとは思わないんですが,こ
>の件について私が感じたことをつらつらと書くと
>
>  * failよりもraiseを使って欲しいなあ

すいません(^^;;; 

# そのうちなくなったりしないですよね?

>  * オブジェクト指向プログラミングではポリモルフィズムのおか
>    げで名称の重複をあまり気にしなくても良いが,いざ重なっちゃ
>    うと大変だよなあ
>
>  * やっぱり名前か…

ですねぇ... 

ちなみに, e2mmap.rbで再定義していました. たぶん, 私しか使っていないと
思うんですが, ほとんどのモジュールで利用しているもので... これを変える
とおおごとになるんですが...

昔のメソッド(fail)は過去の互換性のために残すとして, 名前を変えることに
しました.

PS.
あたらしい, e2mmap-1.2.1.8.rb をincomingにputしておきます. 適当な置換
えをお願いします.

__
................................石塚 圭樹@日本ラショナルソフトェア...
----------------------------------->> e-mail: keiju / rational.com <<---