まつもと ゆきひろです

In message "[ruby-list:9110] Re: irb -m"
    on 98/08/14, GOTO Kentaro <gotoken / math.sci.hokudai.ac.jp> writes:

|ごとけんです

|>最近イテレータブロックという単語は使わないように
|>しているので(あちこち残ってますが),その辺を修正した上で取り
|>込みます.コメントは歓迎です.
|
|なんでもかんでもイテレータブロックと言わないように
|なったのは好ましく思いますが、まさにイテレータとして
|呼ばれたときはそう呼んだ方が良いようにも感じます。

えーと,*最近の*私の方針は

  * do〜endや{〜}の部分はいつも「ブロック」と呼ぶ.

  * ary.each{...}のような各要素に対してブロックを評価するよ
    うな繰り返しを実現するメソッドのことはイテレータと呼ぶ

  * lambda{...}のような「繰り返さない」メソッドのことをイテ
    レータと呼ぶことは許容する.しかし,自分ではブロックが与
    えられたメソッドのような呼び方をしようと考えている

というものです.ですから,「イテレータ」という単語はアリです
が,「イテレータブロック」という単語はワタシ的にはナシです.

# ただRuby本の原稿を書き始めた時点ではこのルールは明確になっ
# てなかったので,古い表現が残ってるかも.気がついたところは
# 直したんですが.

                                まつもと ゆきひろ /:|)