けいじゅ@日本ラショナルソフトウェアです.

In [ruby-list :9110 ] the message: "[ruby-list:9110] Re: irb -m ", on
Aug/14 21:36(JST) GOTO Kentaro writes:

>ごとけんです

>>で,以前にも話が出たような気がするのですが,行列に対してto_i
>>やto_fを行った時に実数や整数ではなく,それらの配列を返すって
>>のはまずいように思います.
>
>同感です。
>Matrix の to_s 以外の to_ は map_to_ とか
>to_mof (matrix of Float) とでもしした方が良いと
>思います。

私も, 変更した方が良いというのはもっともだと思います.

Matrix(Vector)とComplexにある問題ですね. ですので, to_mofはちょっとっ
て気がしますね. 

同じ名前でないと実装の時に苦しむと思います:

Matrix#to_iなどは各要素に対してto_iしていますよね. で, 各要素がto_iを
知っているのでうまく動作しています. 今度は, そうもいかなくなるわけです
よね...

Matrix#to_mofで各要素に対して, to_mofを呼ぶというわけにもいかないです
しね.

ということで, 他に反対がないならmap_to_*がよいんじゃないでしょうか?

>ところで対角化や各種分解や固有値が matrix.rb や
>拡張モジュールで実装される予定はありますか? 

あるといいですよね(^^;;; 

__
................................石塚 圭樹@日本ラショナルソフトェア...
----------------------------------->> e-mail: keiju / rational.com <<---