はじめまして堀と申します。
なぜか下記のスクリプトが動きません。どなたか教えて頂けないでしょうか。

#!/usr/local/bin/ruby

require "tk"

TkButton.new {
         text 'Hello World!
         'command 'exit'
         pack('fill' => 'x')
}

Tk.mainloop

上記を実行したところ、

/usr/local/lib/ruby/tk.rb:408:in `new': Tk_Init (RuntimeError)
        from /usr/local/lib/ruby/tk.rb:408
        from ./tkhello.rb:3

とメッセージが表示されました。

実行環境は、
FreeBSD-2.2.1
ruby-1.1c2
jp-tcl-7.6
jp-tk-4.2

以前ruby1.0をかじっていた時は動いていたんですが。。
どうか宜しくお願いします。

taanoshin / geocities.co.jp