原です。

In message "[ruby-list:7762] Re: mail index sort by From:"
    on 98/04/28, WATANABE Hirofumi <watanabe / ase.ptg.sony.co.jp> writes:
|
|わたなべです.

|  folder.sort{|i,j|
|    (i['From']<=>j['From']).nonzero? or
|    (i['Subject']<=>j['Subject']).nonzero? or
|    i.time<=>j.time
|  }

これが最良ですね。こうしてみると nonzero? って名前長いな
あ。 nzero? あるいは nz? ぐらいで良かった。? も無くてよ
かったような気もする。

String には nonempty? ってないのかな。