千坂@UPUと申します。

 From: matz / netlab.co.jp (Yukihiro Matsumoto)
 Date: Wed, 22 Apr 1998 15:53:53 +0900
 >
 >In message "[ruby-list:7710] Re: How to install beta versions"
 >    on 98/04/22, Toshihiko SHIMOKAWA / 下川俊彦 <toshi / csce.kyushu-u.ac.jp> writes:
 >|とりあえず、見よう見まねで extconf.rb を
 >
 >うーむ,やはりこれが必要な環境は多いようですね.私の環境では
 >なぜかこれらのライブラリを指定しなくてもチェックできてしまう
 >のですが,Debian/Linuxの動的ライブラリは必要なものが埋め込ま
 >れているのでしょうか?

 RedHat Linux 4.2
 gtk+-1.0.0
 ruby-1.1b9
 ruby-gtk-0.04

 という私の環境でも、gtk モジュール が組み込まれないので
 下川さんの方法により make install を行いました。
 

 >|ただし、gtk モジュールについて来たテストスクリプトの一部は動いてくれませ
 >|んでした。とりあえず、すぐにでも必要というわけではないので、ちょっと置い
 >|ておくことにしちゃいました。
 >
 >あ,人柱になってくれるかと思ったのに ^^;;;

 人柱になりたいんですが(^^;)

   # ruby test.rb
   ruby: can't resolve symbol 'make_ttips'
   ruby: can't resolve symbol 'gtk_tooltips_set_tips'
   ruby: can't resolve symbol 'gtk_range_calc_value'
   ruby: can't resolve symbol 'gdk_draw_bitmap'
   test.rb:1:in `require': Unable to resolve symbol - ./gtk.so
                                    (LoadError) from test.rb:1

 とゆう具合で先に進めません。

 % cd /usr/local/gnome/gtk+-1.0.0/gdk
 % grep gtk_tooltips_set_tips *.c
 % grep gtk_tooltips_set_tips *.h
 % grep gtk_range_calc_value *.c
 % grep gtk_range_calc_value *.h
 % cd /usr/local/gnome/gtk+-1.0.0/gdk
 % grep gdk_draw_bitmap *.c
 % grep gdk_draw_bitmap *.h
 gdk.h:void gdk_draw_bitmap	 (GdkDrawable  *drawable,

 GTK のバージョンが違うからでしょうか。(^^;?)

-------------------------------------------
  _o/ Fumio.Chisaka ( chisaka / upu.co.jp )
  //           Think Gnome!
-------------------------------------------