まつもと ゆきひろです

In message "[ruby-list:7310] Re: modulo"
    on 98/04/02, toyofuku / juice.or.jp <toyofuku / juice.or.jp> writes:

|  豊福@パパイヤです。

|  "+!other" は "+! other" と "+ !other" で ambiguous
|でまずいかとも思ったんですが、
|"foo.bar!other" は "foo.bar!(other)" と解釈されるんで、
|"+!" もいいかと parse.y をいじってみました。

うーん,parse.yをいじれる強者の登場は歓迎します.

|  採用されないような気がするので全演算をいじるのは
|やめて "+!" と "*!" だけにしました。

ぴんぽん ^^;;;

さすがに演算子を追加するというような変更はかなり採用しにくい
ですね.メソッドを追加とかならわりと簡単に採用されるんですが.

                                まつもと ゆきひろ /:|)