まつもと ゆきひろです

In message "[ruby-list:6521] Re: perl library and simple_chat_server"
    on 98/02/19, TAKAHASHI Masayoshi <maki / inac.co.jp> writes:

|高橋です。

html生成ライブラリについては知らないのですが.

|>  STDERR.print (Time.now, "\terror! : ", $!, "\n")
|
|という書き方は、ruby1.1b5ではエラーになってしまう(printのあとの空白が
|いけないらしい)のですが、これってやっぱりrubyのversionをあげないとだめ、
|ってことでしょうか?

1.0を使っている場合にはそのままのバージョンに留まる意味があ
るのですが,1.1b5の場合には1.1b7に移行しない理由というのはあ
まり思い付きませんね.もっとも「面倒」という最大の理由はある
わけですが.^^;;;

1.1b8ではどうもTimeあたりに非互換性が出そうなので,移行しな
い理由がもうちょっとあるかもしれません.

今回の場合にはprintと(の間の空白を取り除くだけでOKです.