前田です。

In message "[ruby-list:6147] Re: JRI bug"
OZAWA Sakuro <crouton / po.shiojiri.ne.jp> wrote:

|こっちのバージョンは
|
|crouton@mishra:~/ruby-1.1b6% ./ruby
|System = Java::find_class('java.lang.System')
|p System.getProperty('java.version')
|^D
|"root:08/30/97-09:42"
|crouton@mishra:~/ruby-1.1b6% 
|
|いわゆる blackdown.org の JDK1.1.3v2 です.そちらのはライブラリを新し
|くしないといけないという 1.1.5 でしょうか.

なるほど、前はそのバージョンで動いていたので、そのバージョンで
動かないということは、動かなくなったのはRubyのバージョンが新しく
なってからですね。
# ちなみにうちのはJDK1.1.4で、Glibc2_jdk1.1.5ではないです。

落ちているのは、

  main -> ruby_options -> ruby_process_options -> proc_options
-> load_file -> file_open -> rb_fopen -> fopen

の部分で、fopenに渡される引数も

fname=0xbffffa59 "test.rb", mode=0x80a401d "r"

と問題ないようなのですが、なぜか落ちます:-(

ruby_options辺りの処理の順番が変わってからではないかと思うのですが、
なぜ落ちるのかわかりません。
# Rubyのバージョンを一つずつ試すしかないかなあ...。

-- 
前田 修吾