前田です。

In message "[ruby-list:6120] JRI bug"
OZAWA Sakuro <crouton / po.shiojiri.ne.jp> wrote:

|JRI0.4をmakeしようとしてコケました.(パッチ付けます)

ごめんなさい。
# すごく恥ずかしいバグですね(^^;

|でもって,makeが通ったあとで make test で,
|../ruby:0: [BUG] Segmentation fault
|となってしまった.

うちでもうまく動作しなくなっていました:-(
スクリプトファイルを指定した時に落ちてしまうようです。

#0  0x402ad159 in __kill ()
#1  0x4027c41d in gsignal ()
#2  0x808d5fd in sigsegv (sig=11) at signal.c:317
#3  0xbffff6fc in ?? ()
#4  0x40267603 in _IO_file_fopen ()

ファイルを指定せずに、

soleil[ruby-1.1b5]$ ./ruby
Vector = Java::find_class('java.util.Vector')
v = Vector.new   
v.addElement("hello")
p v
^D

などと標準入力からコードを入力した場合はうまく行くのですが...。

RubyとJavaの両方のバージョンを上げてしまったので、
どちらを変えてからこうなったのかよくわかりません。
# ちなみにjava version "Sergey_Nikitin:11/25/97-11:59"です。

-- 
前田 修吾