こんにちは、なかむら(う)です。

In message "[ruby-list:50517] Re: Rubyinstaller2ではEncoding.default_externalがUTF-8に決め打ち"
  on Thu, 20 Apr 2017 14:59:38 +0900, main / hhiro.net wrote:
> ちなみに、作者が理由まで明確に書いていたわけでないので確実なことは言えないですが、作者がEncoding.default_externalをUTF-8にするようにしたのは、MSYS2ベースに変更した結果なのではないかと推測しています。

偶然なのか何らかの関連があるのかは知りませんが、ちょうど先ほど
RubyInstaller2の作者が"Set Encoding.default_external to UTF-8 on Windows"
というFeatureチケットを作っておられます。
( https://bugs.ruby-lang.org/issues/13488 )

それによりますと(引用中の改行は引用者による挿入)、

| The current setting is a major interoperability issue and it is
| neither useful nor expected, because nobody seriously uses
| the ancient locale dependent cpXYZ encodings for file content.

ということだそうですので、作者氏の観測される世界においては、
UTF-8以外のエンコーディングを使う人が単に存在しない、というのが
理由の模様です。


それでは。
-- 
U.Nakamaura <usa / garbagecollect.jp>