中村さん

デバッガ、インストールできました。

IDE(Netbeans7.1.1、eclipse3.7)で、指定のBPで停止できることも確認しま
した。

インストールしたgemファイルは、以下です。

debug-ideは、NetBeans7.1.1で、Rubyのデバッガを選択したところ、インストール
のメッセージが、表示されたので、
インストール実施したら、インストールされました。


Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

D:\>cd \ruby187p358

D:\Ruby187p358>pik sw 187 358

D:\Ruby187p358>ruby -v
ruby 1.8.7 (2012-02-08 patchlevel 358) [i386-mingw32]

D:\Ruby187p358>gem -v
1.8.22

D:\Ruby187p358>gem list

*** LOCAL GEMS ***

linecache (0.46)
rbx-require-relative (0.0.9)
ruby-debug-base (0.10.4)
ruby-debug-ide (0.4.9)
rubygems-update (1.8.22)

D:\Ruby187p358>

eiichi_maekawa / mhi.co.jp wrote on 2012/04/24 08:54:07:

> 中村さん
>
> ありがとうございます。試してみます。
>
>
> Takashi Nakamura <tk47kmr.0904 / gmail.com> wrote on 2012/04/23 22:34:22:
>
> > 中村 たかしと申します。
> > 私の環境では、gemのproxy設定をしてやらないと、外部への参照ができないの
で
> > proxy設定を削除してやりました。
> > OS:WindosXP sp3でrubyinstaller1.8.7-p358をインストールしてからです。
> > 私はruby-debugを使用してませんので、あくまでgem installでの参考です。
> > 前川さんと違うのは、XXX_mswin32.gemを使っていないことです。
> > i386-mingw32でXXX_mswin32.gemを使うといけないのかは、私にはわかりませ
ん。
> >
> > ERROR:  Could not find a valid gem 'xxxx'が出てから
> > RubyGems.orgより
> > rbx-require-relative-0.0.9.gem
> > ruby-debug-base-0.10.4.gem
> > rubygems-update-1.8.22.gem
> > をダウンロードしています。
> >
> > ruby 1.8.7 (2012-02-08 patchlevel 358) [i386-mingw32]
> >
> > C:\Documents and Settings\xxxxxxxx>gem -v
> > 1.8.16
> >
> > C:\Documents and Settings\xxxxxxxx>cd c:\ruby\DevKit
> >
> > C:\ruby\DevKit>ruby dk.rb init
> > [INFO] found RubyInstaller v1.8.7 at C:/ruby/Ruby187
> > [INFO] found RubyInstaller v1.9.2 at C:/ruby/Ruby192
> > [INFO] found RubyInstaller v1.9.3 at C:/ruby/Ruby193
> >
> > Initialization complete! Please review and modify the auto-generated
> > 'config.yml' file to ensure it contains the root directories to all
> > of the installed Rubies you want enhanced by the DevKit.
> >
> > C:\ruby\DevKit>ruby dk.rb review
> > Based upon the settings in the 'config.yml' file generated
> > from running 'ruby dk.rb init' and any of your customizations,
> > DevKit functionality will be injected into the following Rubies
> > when you run 'ruby dk.rb install'.
> >
> > C:/ruby/Ruby187
> > C:/ruby/Ruby192
> > C:/ruby/Ruby193
> >
> > C:\ruby\DevKit>ruby dk.rb install
> > [INFO] Updating convenience notice gem override for 'C:/ruby/Ruby187'
> > [INFO] Installing 'C:/ruby/Ruby187/lib/ruby/site_ruby/devkit.rb'
> > [INFO] Skipping existing gem override for 'C:/ruby/Ruby192'
> > [WARN] Skipping existing DevKit helper library for 'C:/ruby/Ruby192'
> > [INFO] Skipping existing gem override for 'C:/ruby/Ruby193'
> > [WARN] Skipping existing DevKit helper library for 'C:/ruby/Ruby193'
> >
> > C:\ruby\DevKit>cd C:\Documents and Settings\xxxxxxxx
> >
> > C:\Documents and Settings\xxxxxxxx>gem install ruby-debug-base --local
> > ERROR:  Could not find a valid gem 'ruby-debug-base' (>= 0) in any
> > repository
> >
> > C:\Documents and Settings\xxxxxxxx>dir *.gem
> >  ドライブ C のボリューム ラベルがありません。
> >  ボリューム シリアル番号は xxxx-xxxx です
> >
> >  C:\Documents and Settings\xxxxxxxx のディレクトリ
> >
> > 2011/04/26  14:11    <DIR>          .gem
> > 2012/04/23  17:17           115,200 ruby-debug-base-0.10.4.gem
> >                1 個のファイル             115,200 バイト
> >                1 個のディレクトリ  55,765,815,296 バイトの空き領域
> >
> > C:\Documents and Settings\xxxxxxxx>gem install ruby-debug-base --local
> > ERROR:  While executing gem ... (Gem::DependencyError)
> >     Unable to resolve dependencies: ruby-debug-base requires linecache
> (>=
> > 0.3)
> >
> > C:\Documents and Settings\xxxxxxxx>dir *.gem
> >  ドライブ C のボリューム ラベルがありません。
> >  ボリューム シリアル番号は xxxx-xxxx です
> >
> >  C:\Documents and Settings\xxxxxxxx のディレクトリ
> >
> > 2011/04/26  14:11    <DIR>          .gem
> > 2012/04/23  17:18            28,160 linecache-0.46.gem
> > 2012/04/23  17:17           115,200 ruby-debug-base-0.10.4.gem
> >                2 個のファイル             143,360 バイト
> >                1 個のディレクトリ  55,765,786,624 バイトの空き領域
> >
> > C:\Documents and Settings\xxxxxxxx>gem install ruby-debug-base --local
> > ERROR:  While executing gem ... (Gem::DependencyError)
> >     Unable to resolve dependencies: linecache requires
> rbx-require-relative
> > (> 0.0.4)
> >
> > C:\Documents and Settings\xxxxxxxx>dir *.gem
> >  ドライブ C のボリューム ラベルがありません。
> >  ボリューム シリアル番号は xxxx-xxxx です
> >
> >  C:\Documents and Settings\xxxxxxxx のディレクトリ
> >
> > 2011/04/26  14:11    <DIR>          .gem
> > 2012/04/23  17:18            28,160 linecache-0.46.gem
> > 2012/04/23  17:19             8,704 rbx-require-relative-0.0.9.gem
> > 2012/04/23  17:17           115,200 ruby-debug-base-0.10.4.gem
> >                3 個のファイル             152,064 バイト
> >                1 個のディレクトリ  55,765,655,552 バイトの空き領域
> >
> > C:\Documents and Settings\xxxxxxxx>gem install ruby-debug-base --local
> > Temporarily enhancing PATH to include DevKit...
> > Building native extensions.  This could take a while...
> > Building native extensions.  This could take a while...
> > Successfully installed rbx-require-relative-0.0.9
> > Successfully installed linecache-0.46
> > Successfully installed ruby-debug-base-0.10.4
> > 3 gems installed
> > Installing ri documentation for rbx-require-relative-0.0.9...
> > Installing ri documentation for linecache-0.46...
> > Installing ri documentation for ruby-debug-base-0.10.4...
> > Installing RDoc documentation for rbx-require-relative-0.0.9...
> > Installing RDoc documentation for linecache-0.46...
> > Installing RDoc documentation for ruby-debug-base-0.10.4...
> >
> > C:\Documents and Settings\xxxxxxxx>gem list
> >
> > *** LOCAL GEMS ***
> >
> > linecache (0.46)
> > rbx-require-relative (0.0.9)
> > ruby-debug-base (0.10.4)
> >
> > C:\Documents and Settings\xxxxxxxx>dir *.gem
> >  ドライブ C のボリューム ラベルがありません。
> >  ボリューム シリアル番号は xxxx-xxxx です
> >
> >  C:\Documents and Settings\xxxxxxxx のディレクトリ
> >
> > 2011/04/26  14:11    <DIR>          .gem
> > 2012/04/23  17:18            28,160 linecache-0.46.gem
> > 2012/04/23  17:19             8,704 rbx-require-relative-0.0.9.gem
> > 2012/04/23  17:17           115,200 ruby-debug-base-0.10.4.gem
> > 2012/04/23  17:24           260,096 rubygems-update-1.8.22.gem
> >                4 個のファイル             412,160 バイト
> >                1 個のディレクトリ  55,762,874,368 バイトの空き領域
> >
> > C:\Documents and Settings\xxxxxxxx>gem update --system --local
> > Updating rubygems-update
> > Successfully installed rubygems-update-1.8.22
> > Installing RubyGems 1.8.22
> > RubyGems 1.8.22 installed
> >
> > == 1.8.22 / 2012-04-13
> >
> > * 4 bug fixes:
> >
> >   * Workaround for psych/syck YAML date parsing issue
> >   * Don't trust the encoding of ARGV. Fixes #307
> >   * Quiet default warnings about missing spec variables
> >   * Read a binary file properly (windows fix)
> >
> >
> >
>
------------------------------------------------------------------------------

>
> >
> > RubyGems installed the following executables:
> >         C:/ruby/Ruby187/bin/gem
> >
> > RubyGems system software updated
> >
> > C:\Documents and Settings\xxxxxxxx>gem -v
> > 1.8.22
> >
> > C:\Documents and Settings\xxxxxxxx>gem list
> >
> > *** LOCAL GEMS ***
> >
> > linecache (0.46)
> > rbx-require-relative (0.0.9)
> > ruby-debug-base (0.10.4)
> > rubygems-update (1.8.22)
> >
> > C:\Documents and Settings\xxxxxxxx>
> >
> >
> > 2012年4月20日14:46 前川 映一 <eiichi_maekawa / mhi.co.jp>:
> >
> > >
> > > 前川です。
> > >
> > > debug-ide、debug-baseをインストールするとエラーが、生じます。
> > >
> > > バージョンと、インストール結果は以下のとおりです。
> > >
> > >
> > > バージョン;;
> > > O/S;;
> > > Microsoft Windows XP [Version 5.1.2600]
> > > (C) Copyright 1985-2001 Microsoft Corp.
> > >
> > > Ruby;;
> > > C:\Documents and Settings\??????>ruby -v
> > > ruby 1.8.7 (2012-02-08 patchlevel 358) [i386-mingw32]
> > >
> > > gem;;
> > > D:\Ruby187p358>gem -v
> > > 1.8.16
> > >
> > > インストール結果;;
> > > D:\Ruby187p358>gem install ruby-debug-base-0.10.3-mswin32.gem --no-ri
> > > --no-rdoc --local
> > > WARNING: linecache-0.43-x86-mswin32 has an invalid nil value for
> > > @cert_chain
> > > WARNING: ruby-debug-base-0.10.3-x86-mswin32 has an invalid nil value
> for
> > > @cert_chain
> > > Successfully installed linecache-0.43-x86-mswin32
> > > Successfully installed ruby-debug-base-0.10.3-x86-mswin32
> > > 2 gems installed
> > >
> > > D:\Ruby187p358>gem uninstall ruby-debug-base-0.10.3-mswin32.gem
> > > INFO:  gem "ruby-debug-base-0.10.3-mswin32.gem" is not installed
> > >
> > > D:\Ruby187p358>gem uninstall linecache-0.43-x86-mswin32
> > > INFO:  gem "linecache-0.43-x86-mswin32" is not installed
> > >
> > > windows版でインストールできる
linecache、ruby-debug-base、ruby-debug-ide
> 
> > > バージョンを
> > >
> > > 教えていただけないでしょうか。
> > >
> > > gemファイルは、すべて、ダウンロードして、ローカルでインストールしてい
ま
> す。
> > >
> > > よろしくお願いします。
> > >
> > >
> > >
> >
> >
> > ====
>
>
>
> ====