前川です。

手始めに、IDEでdebugするための事前準備として、devkitをruby1.9.3p0にインス
トールしましたが、ダメっぽいです。

D:\DevKit>ruby dk.rb install
[INFO] Skipping existing gem override for 'D:/Ruby193p0'
[WARN] Skipping existing DevKit helper library for 'D:/Ruby193p0'

となりました。

Ruby1.9.2p290では、

D:\DevKit>ruby dk.rb install
[INFO] Updating convenience notice gem override for 'D:/Ruby192p290'
[INFO] Installing 'D:/Ruby192p290/lib/ruby/site_ruby/devkit.rb'

となったのですが・・・

原因は、何でしょうか?

使用しているdevkitは、http://rubyinstaller.org/downloads/ からダウンロード
したものです。

O/S、Rubyのバージョンは、以下です。よろしくお願いします。

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\xxxxxxx>pik list
  187: ruby 1.8.7 (2011-06-30 patchlevel 352) [i386-mingw32]
  192: ruby 1.9.2p180 (2011-02-18) [i386-mingw32]
* 192: ruby 1.9.2p290 (2011-07-09) [i386-mingw32]
  193: ruby 1.9.3p0 (2011-10-30) [i386-mingw32]

C:\Documents and Settings\xxxxxxx>pik sw 193

C:\Documents and Settings\xxxxxxx>ruby -v
ruby 1.9.3p0 (2011-10-30) [i386-mingw32]

>
> 前川です。
>
> Ruby1.9.3p0 windows版(mingw)で、MYSQLを使いたいのですが、
>
> Gemのバージョンが、1.8.11となっていますが、問題ないでしょうか?
>
> 以前、1.9.2p290で、Mysqlを使おうとしましたが、deprecatedエラーとなり、gem
を
> 1.5.2に
>
> ダウングレードしたことがありました。
>
> また、gem関連ファイルは、
>
> deprecated-2.0.1.gem、mysql-2.8.1-x86-mswin32.gem を使う予定です。
>
> 事情により、ローカルでインストールします。
>
> すでに、wnidows版で、ruby1.9.3p0を使っている方がいましたら、
>
> Mysql関連のgemファイルを教えていただいたら、助かります。
>
> よろしくお願いします。
>
>