こんにちは、なかむら(う)です。

In message "[ruby-list:47715] Windowsで1.9.2p136+zlibのインストール"
    on Dec.27,2010 13:27:46, <aoki / livretech.co.jp> wrote:
> あおきと申します。
> 
> Ruby 1.9.2-p136をVC 2003でコンパイルしています。
> 今回初めてzlibもいれようとした所うまくできませんでした。

とりあえず、頂いた情報では再現ができないので追試すらままなり
ません。


> その後ダウンロードしたzlib 1.2.5から

どこから入手したどのファイルですか?


>   ruby extconf.rb

これはrubyの配布物中の ext/zlib で実行したということでしょう
か?


> が通るように zlib.h,zconf.h, zdll.lib を
> rubyのインストール先のlib,includeに配置して
> 
>   nmake
>   nmake install
> 
> もうまくいっているように見えます。.so も site_ruby に入っていました。
> 
> zlib1.dllをruby.exeと同じパスに置いて,

とりあえず、ここまでは、あんまり普通ではないような気がするこ
とも幾つかありますが、実用上は問題ないレベルの内容に見えます。


>   gem list --local
> 
> とすると,エラーダイアログが表示され

問題点をzlibに限定したいので、

  ruby -rzlib -e0

で何が起きるのかを説明していただくのがよいと思います。


それでは。
-- 
U.Nakamura <usa / garbagecollect.jp>