アドバイスありがとうございます。

>> ・gem で rdoc の最新版をインストールしても最新版を使ってくれない気がする
>
> gemは、依存関係を見て、新しくインストールしようとしているパッケージの最新版が、
> 既にインストールされているパッケージのより新しい版に依存している場合、
> 古い版をインストールするようです。
>
> 試したわけではないのでこの場合にあてはまっているかわかりませんが、最新版を
> 入れたい場合は、まずgem updateをしたほうがいいようです。

今回の件は、以下の事により起きていると考えています。
・標準添付の rdoc が gem 管理下にない
・gem より、デフォルト LOAD_PATH が優先される

標準ライブラリが gem 管理下になれば、こういう弊害は起きないのかなとか考えておりますが、
そういう予定はないのでしょうか?