Ruby初心者の前川です。

我流で、Rubyを使っていますが、バージョンアップ方法について、教えていただき
たく、
宜しくお願いします。

現在のバージョンは、以下です。

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\>ruby -v
ruby 1.8.7 (2010-01-10 patchlevel 249) [i386-mswin32]

C:\>gem list --local

*** LOCAL GEMS ***

actionmailer (2.3.4)
actionpack (2.3.4)
activerecord (2.3.4)
activeresource (2.3.4)
activesupport (2.3.4)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
deprecated (2.0.1)
eventmachine (0.12.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
linecache (0.43)
mongrel (1.1.5)
mysql (2.8.1)
rack (1.0.0)
rails (2.3.4)
rake (0.8.7)
ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.5)
sinatra (0.9.4)
sqlite3-ruby (1.2.5)
thin (1.2.4)

Railsの分も一部含んでますが、Ruby187p299へのバージョンアップは、

ダウンロードした ruby-1.8.7-p299-i386-mswin32.zip を解凍し、
解凍したフォルダの中身(bin他)のみを、Rubyフォルダにコピー(上書き)する方
法としました。

その結果、が以下です。

C:\>ruby -v
ruby 1.8.7 (2010-06-23 patchlevel 299) [i386-mswin32]

C:\>gem list --local

*** LOCAL GEMS ***

actionmailer (2.3.4)
actionpack (2.3.4)
activerecord (2.3.4)
activeresource (2.3.4)
activesupport (2.3.4)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
deprecated (2.0.1)
eventmachine (0.12.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
linecache (0.43)
mongrel (1.1.5)
mysql (2.8.1)
rack (1.0.0)
rails (2.3.4)
rake (0.8.7)
ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.5)
sinatra (0.9.4)
sqlite3-ruby (1.2.5)
thin (1.2.4)

事情があり、gemは、すべて、ダウンロードし、ローカルでインストールしています。

Rubyのバージョンアップは、187系であれば、上記方法で問題ないと思っています
が、
いかがでしょうか?

ご指導のほど、宜しくお願いします。

了