植田です。


> Wed, 2 Sep 2009 02:42:56 +0900 のメールにて、
> "NARUSE, Yui" <naruse / airemix.jp> さんは書きました :
> 
> > 成瀬です。
;
> > この違いが影響しているならば、とりあえず直接の犯人に見える、
> > RubyGemsを新しくしてみてはどうでしょう。

prawn(http://github.com/sandal/prawn/issues)の中で enumerator が require 
されていたので 1.8.7 の exerb 化したバイナリでエラーになると報告したとこ
ろ、「1.8.7 に対応してないし、後方互換性の点で外せない。exerb プロジェク
トに聞いて欲しい」といわれました。

	http://github.com/sandal/prawn/issues/closed#issue/34

 とりあえず手元では

begin
  require 'prawn'
rescue LoadError
end

して逃げておきます。


以上、報告でした。


-----
株式会社ネットフォレスト            http://www.netforest.ad.jp/
Dr.Web/Vade Retro 担当 植田 裕之   ueda / netforest.ad.jp
tel:045-663-6277 fax:045-663-6278