(2009年09月02日 15:29), rubikitch / ruby-lang.org さんは書きました:
>> 標準で添付されているライブラリをrequireする時に、一部のライブラリでLoadErrorが出てしまいます。
>> いろいろと調べて見たのですが、原因がよくわかりません。どなたかご教示お願いします。
>> 具体的には、
>> require 'openssl'
>> というスクリプトを実行すると、
>> test.rb:1:in `require': no such file to load -- openssl (LoadError)
>>        from test.rb:1:in `<main>'
>> というエラーが出てきてしまいます。
>> 他のいくつかのライブラリについても確認してみたのですが、tk、zlib、curses、dbm、gdbmなどのライブラリでエラーが出てきます。
> 
> おそらくRubyはdebからインストールしたのでしょう。
> debian系列だと細かいパッケージに分かれています。

少なくともzlibやcursesは別パッケージになっていませんので
debパッケージを使ってたのではない可能性が高そうです。

インストールした際に必要な開発環境が
整っていなかったのではないかなと思います。

-- 
やまだ
# i686-linuxだという時点でdebパッケージではなさそうな気が。