北村と申します。最近Rubyを始めた初心者です。

標準で添付されているライブラリをrequireする時に、一部のライブラリでLoadErrorが出てしまいます。
いろいろと調べて見たのですが、原因がよくわかりません。どなたかご教示お願いします。
具体的には、
require 'openssl'
というスクリプトを実行すると、
test.rb:1:in `require': no such file to load -- openssl (LoadError)
       from test.rb:1:in `<main>'
というエラーが出てきてしまいます。
他のいくつかのライブラリについても確認してみたのですが、tk、zlib、curses、dbm、gdbmなどのライブラリでエラーが出てきます。
すべてのライブラリに対してエラーが起きるわけではなく、csvやnkfなど多くのライブラリでは正常に実行されます。

実行環境は、
Ruby:ruby 1.9.1p243 (2009-07-16 revision 24175) [i686-linux]
OS:Ubuntu 9.04
です。