植田と申します。

 ActiveScriptRuby 1.8.7 と同梱されている Exerb 4.9.0 を使って、ruby ス
クリプトを exe 化したのですが、その exe を実行すると以下のエラーが出てし
まいます。

C:\work\SVN-Repos\Dr.Web\trunk\script\license>generator.exe
rubygems/custom_require.rb:31:in `gem_original_require': No such file to load --
 enumerator (LoadError)
        from rubygems/custom_require.rb:31:in `require'
        from prawn/graphics.rb:9

"enumerator" が無いといわれていますが、検索する限り enumerator.* を見つ
けることができませんでした。

※ ruby xxxx.rb では動きますので、プログラムそのものの問題ではないと思い
  ます。


 1.8.6 の時には exerb で exe 化しても動いていたのですが、そのときの 
exerb レシピファイルと比べると

  etc.so:
    file: C:/PROGRA~1/ruby-1.8/lib/ruby/1.8/i386-mswin32/etc.so
    type: extension-library

という箇所が 1.8.7 のレシピファイルではなくなっています。この辺りの違い
なのでしょうか?


 1.8.6 環境から 1.8.7 環境へ入れ替える際に何かミスをしたのかもしれませ
んがイマイチよく分かりません。どなたかご教授いただければ幸いです。

-----
株式会社ネットフォレスト            http://www.netforest.ad.jp/
Dr.Web/Vade Retro 担当 植田 裕之   ueda / netforest.ad.jp
tel:045-663-6277 fax:045-663-6278