前川です。

坂口さん ありがとうございます。

> 環境変数 RUBYOPT が設定されていませんか?
> 例えば、Windows で One-Click Installer でインストールすると自動的に
> RUBYOPT=-rubygems
> が追加されます。するとデバッガを用いると上記のようになります。

確かに、設定されていました。
One-Click Installerで、1.8.6をインストールしています。

環境変数を削除した結果,

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\M118543>cd
C:\Apache2.2\htdocs\qmsPotalShip\confirmation

C:\Apache2.2\htdocs\qmsPotalShip\confirmation>ruby -r debug
myclassMySQLTest.rb
Debug.rb
Emacs support available.

myclassMySQLTest.rb:11:require
"C:/Apache2.2/htdocs/qmsPotalShip/myclass.rb" #共通クラス(含むRubyのクラ
ス)
(rdb:1)

となりました。

了