阪口ともうします。とりあえず、1点だけ即応させてもらうと、

In message <OF930C2DD8.D1E9FCE6-ON492575ED.0017E632-49257609.0021649C / mhi.co.jp> 2009-08-05T15:04+0900,
	前川 映一 <eiichi_maekawa / mhi.co.jp> wrote:
> また、デバッガで起動した場合、必ず
> c:/ruby/lib/ruby/site_ruby/1.8/ubygems.rb:10:require 'rubygems'
> (rdb:1)
> が、表示されます。

環境変数 RUBYOPT が設定されていませんか?

例えば、Windows で One-Click Installer でインストールすると自動的に

RUBYOPT=-rubygems

が追加されます。するとデバッガを用いると上記のようになります。

--
阪口哲男@図書館情報メディア研究科.大学院.筑波大学
Tetsuo SAKAGUCHI.
Graduate School of Library, Information and Media Studies
University of Tsukuba, JAPAN.