From: Akira Hayakawa <ruby / i-mail.jp>
Subject: [ruby-list:45401] Re: JRubyについて&rubygemについて&RDTについて
Date: Tue, 26 Aug 2008 10:59:57 +0900

> ruby1.9をapt-getしたのですが、
> /var/lib/gemsに1.8/しかありません。1.9をインストールするとここに1.9がインストールされるのではないのですか?

Debian GNU/Linuxでしょうか?
Debianではrubygems1.9は別パッケージになっています。

Ruby 1.9をソースからインストールするともれなくRubyGemsもついてきます。

# これはあくまでディストリビューションのパッケージングの話

> $ ls /usr/lib/ruby/
> 1.8  1.9.0
> 
> このディレクトリには、1.8と1.9.0がありますが、1.8の方が1.8.xが省略されているのにも関わらず、1.9の方は1.9.0まで表示されてるのはなぜでしょうか?

仕様です。理由は失念。ruby-devのどこかに書いてあった気が(^^;

> また、
> $ sudo ruby1.9 -S gem install rails
> こうやってrailsを入れようとしたら、

現在のRuby on RailsはRuby 1.9に対応していません。

--
rubikitch
Blog: http://d.hatena.ne.jp/rubikitch/
Site: http://www.rubyist.net/~rubikitch/