木村です。

Kura syuu さんは書きました:
>  Kura syuuです。
> 
> RUBYOPT=rubygems  です。
> 

>>> これはどのバイナリ配布のものですか?
> 質問がよくわかりません。


上記の環境変数が設定されているので、常に gems 関連の require がされる
ようになっているので、これがcygwinのrubyが動かない原因です。

おそらく、先にインストールしたであろう

>>> ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]は正常に動作します。

これのインストーラーが設定したと思われるので、どこかでバイナリ形式で
配布しているものだろうということでその詳細を訊きたかったのです。


-- 
木村浩一/KIMURA Koichi
 I thought what I'd do was, I'd pretend I was one of those deaf-mutes or
shoud I?
 mail kbk at kt.rim.or.jp
 web  www.kt.rim.or.jp/~kbk/zakkicho/index.html