かずひこです。
On Tuesday 06 March 2007 23:49, Hideo Konami wrote:
> ruby 1.8.5 (2006-12-25 patchlevel 12) [i686-linux]> Linux version 2.4.27-2-686 (horms / tabatha.lab.ultramonkey.org) (gcc version> 3.3. 5 (Debian 1:3.3.5-12)) #1 Mon May 16 17:03:22 JST 2005>> ぐぐってみたら,ext/zlib の下で> ruby extconf.rb --with-zlib-include=/usr/include --with-zlib-lib=/usr/lib> をやったらうまくいったという記事を見つけたのですが,これもこけて,Makefile を生成してくれません。
zlibの開発環境が入っていないからだと思います。Debianならzlib1g-devパッケージを入れてください。
その後でrubyをconfigure -> makeするか、ext/zlibの下で上記のようにしてからmake installすれば、zlib.soがインストールされて、 require "zlib"が通るようになって、解決すると思います。
かずひこ