小波です。この問題は既出のような気がしたのですが,過去ログでは見つけられ
なかったので,教えていただけないでしょうか。


rubygems-0.9.2 をインストールしようとして,ruby setup.rb  を実行したと
ころ,下に貼り付けてあるエラーが出て止まってしまいます。Ruby と OS
のバージョンは次の通りです。

ruby 1.8.5 (2006-12-25 patchlevel 12) [i686-linux]
Linux version 2.4.27-2-686 (horms / tabatha.lab.ultramonkey.org) (gcc version 3.3.
5 (Debian 1:3.3.5-12)) #1 Mon May 16 17:03:22 JST 2005

ぐぐってみたら,ext/zlib の下で
ruby extconf.rb --with-zlib-include=/usr/include --with-zlib-lib=/usr/lib 
をやったらうまくいったという記事を見つけたのですが,これもこけて,Makefile を生成してくれません。

少々八方ふさがり状態になってしまったので,助けていただけると幸いです。

--------------- setup.rb 実行時のエラーメッセージ -----------
<--- lib
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_fetcher.rb:4:in `require': no 
such file to load -- zlib (LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_fetcher.rb:4
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:8:in `re
quire'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:8
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:501:in `require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:501
        from /root/work/rubygems-0.9.2/./post-install.rb:81:in `require'
        from /root/work/rubygems-0.9.2/./post-install.rb:81:in `install_sources'
        from /root/work/rubygems-0.9.2/./post-install.rb:116:in `try_run_hook'
        from setup.rb:584:in `run_hook'
        from setup.rb:1322:in `exec_task_traverse'
        from setup.rb:1175:in `exec_install'
        from setup.rb:894:in `exec_install'
        from setup.rb:712:in `invoke'
        from setup.rb:681:in `invoke'
        from setup.rb:1359
---------------------------------------------------------------------