なかだです。

At Sun, 20 Aug 2006 04:40:54 +0900,
きむらこういち wrote in [ruby-list:42727]:
> > ansi.sys を組み込めばいけるんでないでしょうか?
> > 後は cygwin とか.
> 
> ansi.sysを組み込んでエスケープシーケンスが使えるようになるのは
> 16bitプログラムだけだったと思います。したがって32bitプログラム
> であるRubyからはエスケープシーケンスによる制御はできないかと。

Windows2000からでしたっけ、エスケープシーケンスがいきなりサポー
トされなくなってしまったのは?

> cygwin版はできるかもしれませんが、確かめてません。

cygwinはcursesがインストールされていれば可能です。Windows用の
cursesにはPDCursesなどがあります。

  http://pdcurses.sourceforge.net/

-- 
--- 僕の前にBugはない。
--- 僕の後ろにBugはできる。
    中田 伸悦