永井@知能.九工大です.

From: "Nobuyoshi Nakada" <nobu / ruby-lang.org>
Subject: [ruby-list:42635] Re: Ruby インストールできません
Date: Tue, 8 Aug 2006 11:26:04 +0900
Message-ID: <cebd6fd10608071926k65255cafo1a2357c21eaa46eb / mail.gmail.com>
> > rpm -q ruby で見ると,ruby-1.8.1-0vl20.2 などと出るでしょうから,
> > 普通は rpm コマンドでそのパッケージ名を指定して消去するということに
> > なるのでしょうけど,依存関係の絡みがあるので簡単ではないかもしれません.
> 
> 消さなくても、rpmなら-Uで更新ができるはずです。

記憶違いでなければ,Vine の標準の rpm パッケージには
新しいバージョンのものは提供されていなかったと思います.
ですので,-U の対象となるパッケージがないんです.
もちろん他のディストリビューションのものを強制的に入れることは
可能ですが,それはそれで中途半端になる恐れがありますから
消すか共存するかにするのが吉かなと...
-- 
                                       永井 秀利 (九工大 知能情報)
                                           nagai / ai.kyutech.ac.jp