Beyond です。

> YAMLはUTF-8にしか対応していません。

そうですね。
それを書いておけば、良かったですね。

ちなみに、t_yaml3.rb でも coreをはきました。

$ ruby t_yaml3.rb
/usr/local/lib/ruby/1.8/yaml.rb:133: [BUG] Segmentation fault
ruby 1.8.5 (2006-08-06) [i386-cygwin]

Aborted (core dumped)

-------------------------------- t_yaml3.rb
#! ruby

require 'yaml'

s = <<'END'
---
str: "c:\"
END

p YAML::load( s )


---------------------
Beyond