Ruby超初心者です。
WindowsにVMWare+Vine(ゲストOS)の環境で
Rubyをインストールしようとしています。
もともとVineにRuby1.8.2が入っていたため、
RubyはそのままでRubyGemsをインストールしました。
VMWare上のVineではネットにつながらないため、
Railsを--localで地道にインストールしました。
これでRoR環境が整ったと思い、
#rails /www/test
とすると、
 Rails requires Ruby version 1.8.2 or later.
 You're running 1.8.2; please upgrade to continue.
と出るのでRubyのアップグレードが必要かなっと思いました。
そこで、Ruby1.8.4を落としてきて、
#tar xzf ruby-1.8.4.tar.gz
#cd ruby-1.8.4
#./configure
#make
#make test
#sudo make install
としたのですが、#make testでは成功したのに、
途中でRuntimeErrorとなってしまいます。
エラーの詳細は、
./miniruby ./ext/extmk.rb --dest-dir="" --make="make"
--mflags="" --make-flags="" --extout=".ext" --extension
--extstatic -- install
cp -r ./.ext/. /usr/local/lib/ruby/1.8
/tmp/tmp/ruby-1.8.4/lib/fileutils.rb:1237:in 'copy':
unknown file type: ./.ext/. (RuntimeError)
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:447:in
'copy_entry'
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:1306:in
'traverse'
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:445:in
'copy_entry'
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:423:in 'cp_r'
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:1377:in
'fu_each_src_dest'
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:1391:in
'fu_each_src_dest0'
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:1375:in
'fu_each_src_dest'
	from /tmp/tmp/ruby-1.8.4/lib/fileutils.rb:422:in 'cp_r'
	from ./ext/extmk.rb:383
make: *** [do-install-ext] エラー 1

Ruby超初心者なので、細かい部分もお教えいただけたら嬉しい
です。m(__)m