たむらです。

nqa58508 / nifty.com wrote:
> はやしです。
> ご連絡有り難うございました。
> 
>> とりあえず ruby -v の結果を知りたいなぁってのと
>> libmysql.dll のコピーとかはやりました?

>  ruby-v では、次のように出て問題ないと思いますが。
> ruby 1.8.4(2005-12-24) [i386-mswin32]

One Click Installer版ですね。うちのも同じ(^^

>   また、手順2.にあるMySQL\binディレクトリにあるlibmysql.dllは
>  間違いなく、ruby\binディレクトリにコピーして貼り付けました。

なるほど。
結果から言うと、Mysql-winのバイナリ(libmysql.dll)のバージョンが原因みた
いです。

5.0.18 (from xampp)    OK
5.0.22 (5.0系最新)     OK
5.1.9 beta             NG  (同じメッセージで再現しました)
5.1.11 beta(5.1系最新) NG  (  〃  )

きちんとは調べてないのですが、5.1xから VC2005に変えたとか、そんなこと
じゃないかと。

配布元でも Instant Railsユーザー向けの注意とか、exampleも 5.0系で試して
るみたいですから。

-- 
たむらけんいち<URL:http://d.hatena.ne.jp/tamura/>
Gmailしたい方、メールください(残:96)