まつもと ゆきひろです

In message "Re: [ruby-list:42265] mime_header.rb(Re: NKF MIME encode problem)"
    on Sat, 27 May 2006 17:13:16 +0900, しん <dezawa / aliadne.net> writes:

|3. Stringクラスに追加したmethod名
|   encode64、decode64 はどういうencodeか意味不明なので
|   Base64 encode で、mime header用のである  という事を表すために
|	encode_header_B64, decode_hader_B64
|   にしました。
|   長いなぁ、、、、

うーん、headerはメソッドを使ううえで必要な情報ではないですし、
B64よりはbase64の方が名称として一般的な気がしますから、

  base64_encode / encode_base64
  base64_decode / decode_base64

の方がよろしいのではないかと思います。いかがでしょう。