天野竜太郎です。
10.4標準添付のrubyに関してはすでにF&Qという感じです 
が(Appleのバグらしいです)

1、/usr/lib/にlibreadline.dylibがlibeditのシ 
ンボリックリンクとして作られていますが、これがうまく動かないよう 
です。
2、/usr/lib/ruby/1.8/powerpc-darwin8.0/rbconfig.rbにバグ 
がある。

以上の理由により標準のままでは拡張ライブラリがコンパイルできませ 
ん。
標準添付のRubyを生かす場合は以下のようにします。
以下のページにいく。
http://wiki.rubyonrails.com/rails/show/HowtoInstallOnOSXTiger
「4. Manually fixing Ruby」のところにあるrbconfig.rb 
をダウンロード。

sudo cp rbconfig.rb /usr/lib/ruby/1.8/powerpc-darwin8.0/
sudo rm /usr/lib/libreadline*
(/usr/lib/にlibreadline.dylibがlibeditのシンボリック 
リンクとして作られている。これを削除する)
自分で、readline4.3あるいは5.0を/usr/local以下 
にインストールする。
sudo ln -s /usr/local/lib/libreadline* /usr/lib/
curl ftp://ftp.ruby-lang.org/pub/ruby/ruby-1.8.2.tar.gz
tar xzf ruby-1.8.2.tar.gz
cd ruby-1.8.2/ext/readline/
ruby extconf.rb
make && sudo make install

以上です。自分でreadlineインストール後にrubyの新しい 
バージョンをインストールする場合は、これまで通り問題ありません。
10.4は、tkがあらかじめインストールされており、標準の 
rubyでも、新しくrubyをインストールした場合でもX11を 
立ち上げずにruby-tkが使えるのは嬉しいです。

On 2005/09/04, at 20:45, 石井 大海 wrote:

> 補足です。
>
> 判りにくかったと思いますが、コンパイルできなかったのは、 
> readlineの拡張モジュールです。
>
>
> 一旦、/usr/local直下のreadlineをアンインストール 
> し、extconfを実行してみました。
>
> ***ここから
> checking for tgetnum() in -lncurses... yes
> checking for readline/readline.h... yes
> checking for readline/history.h... yes
> checking for readline() in -lreadline... no
> ***ここまで
>
> このようなログがはかれたのですが、参考になりますでしょうか?
>
>

Ryutaro Amano
wn9r-amn / asahi-net.or.jp