In message <4312C85B.5000700 / kyoto-wu.ac.jp>,
 `Hideo Konami <konami / kyoto-wu.ac.jp>' wrote:
> の処理でつかえてしまうようです。下のレポートに追加しておきました。
> よろしくお願いします。
> 
> http://www.cs.kyoto-wu.ac.jp/~konami/work/cantmakeruby.html

これもOpenSSL 0.9.8ではエラーになってしまいます。CVS版では修
正済みですので、スナップショットか

  http://www.ruby-lang.org/cgi-bin/cvsweb.cgi/ruby/ext/openssl/ossl_x509store.c.diff?r1=1.2.2.3;r2=1.2.2.4;only_with_tag=ruby_1_8

こちらのパッチを試していただけないでしょうか。

ちなみに、ext/digestはconfigureの際に、

  --with-bundled-rmd160
  --with-bundled-sha1
  --with-bundled-md5

を追加すると、OpenSSLを使わずにコンパイルできるようです。

-- 
ごとうゆうぞう