こんにちは、ふじもとです。

ちょうど、きのう OS X 10.4.1 に rubygems で ruby-sqlite3 と
activerecord (というかrails)を入れて試してみたところです。

At Sat, 4 Jun 2005 20:46:13 +0900,
Hiromi Ishii wrote:
> 
> konnです。
> 
> > sqlite-ruby はどのバージョンをお使いですか。
> > http://wiki.rubyonrails.com/rails/show/FAQ
> もりきゅうさん、早速のレスありがとう御座います。
> sqlite-ruby (2.2.3) です。私はあんまり英語は得意ではないのですが、
> このページに書いてあるのは、rubygemsでインストールしてはいけないと云うことな
> んでしょうか?
> これはrubygemsで組み込んだので、となると手動でインストールする必要があると言
> うことなんでしょうか?

10.4.1 には (sqliteではなく)sqlite3 が最初から入ってたので、gem で
sqlite-ruby ではなく sqlite3-ruby (1.1.0) を入れました。るびまの記事
(http://jp.rubyist.net/magazine/?0004-RLR) を読みながら試してみて、動き
ました。

#!/usr/bin/env ruby
require 'rubygems'
require_gem 'activerecord'
class Student < ActiveRecord::Base
	def self.table_name() "student" end

	def introduce
		return "Hello, my name is %s." % name
	end
end
require 'logger'
ActiveRecord::Base.logger = Logger.new("debug.log")
ActiveRecord::Base.establish_connection(
	:adapter  => "sqlite3", :dbfile => "ar.db" )
student = Student.find_all("name = 'Alan Mathison Turing'")[0]
puts student.introduce

-- 
FUJIMOTO Hisa