初めまして。konnと言います。

OSX10.4.1 + ruby 1.9.0 (2005-05-01) [powerpc-darwin8.0.0] + mysql  Ver 14.7
Distrib 4.1.12, for apple-darwin7.9.0 (powerpc) using readline 4.3を使ってい
ます。

ここに、mysql-ruby-2.6をinstallしたいのですが、下記のようなエラーが出てしまい
ます。

$ ruby extconf.rb --with-mysql-dir=/usr/local/mysql
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lm... yes
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lz... yes
checking for mysql_query() in -lmysqlclient... yes
checking for mysql_ssl_set()... yes
checking for mysql.h... yes
creating Makefile

$ make
gcc -fno-common -g -O2 -pipe -fno-common  -I.
-I/usr/local/lib/ruby/1.9/powerpc-darwin8.0.0
-I/usr/local/lib/ruby/1.9/powerpc-darwin8.0.0 -I. -DHAVE_MYSQL_SSL_SET
-DHAVE_MYSQL_H -I/usr/local/mysql/include -I/sw/include  -c mysql.c
mysql.c: In function ‘query’:
mysql.c:635: error: invalid storage class for function ‘res_free’
make: *** [mysql.o] Error 1     <----- これ

どうすれば無事コンパイルできるのでしょうか。どなたか教えて下さい。

---
☆★konn★☆
Good bye...
---