はじめまして、舘石といいます。

rdindex-1.2.2.tar.gzをcygwin上でインストールしたいのですが、
以下のようなエラーでうまくいきません。

$ ruby setup.rb setup
(略)
/home/hoge/tmp/rdindex-1.2.2/bin/rdindex/rdindex:2:in
 `require': No such file to load -- rdindex (LoadError)
        from /home/hoge/tmp/rdindex-1.2.2/bin/rdindex/rdindex:2
/home/hoge/tmp/rdindex-1.2.2/bin/rdindex/rdindex:2:in
 `require': No such file to load -- rdindex (LoadError)
        from /home/hoge/tmp/rdindex-1.2.2/bin/rdindex/rdindex:2
/home/hoge/tmp/rdindex-1.2.2/bin/rdindex/rdindex:2:in
 `require': No such file to load -- rdindex (LoadError)
        from /home/hoge/tmp/rdindex-1.2.2/bin/rdindex/rdindex:2
(略)

tar の中身は、
$ tar -xzvf rdindex-1.2.2.tar.gz
rdindex-1.2.2/setup/rdindex.rb
rdindex-1.2.2/rdindex.ja.rd
rdindex-1.2.2/rdindex.ja.html
rdindex-1.2.2/share/PATHCONV
rdindex-1.2.2/share/rdindex/rdindex.el
rdindex-1.2.2/share/rdindex/rdindex-init.el
rdindex-1.2.2/bin/PATHCONV
rdindex-1.2.2/bin/rdindex/rdindex
rdindex-1.2.2/bin/rdindex/rdindex.bat
rdindex-1.2.2/lib/PATHCONV
rdindex-1.2.2/GPL
rdindex-1.2.2/setup.rb
rdindex-1.2.2/dot.rdindex

です。

libフォルダの下に本来あるはずのrubyライブラリを
requireしようとして失敗しているように思うんですが・・・
なにか、見当違いのことを言っていたらすみませんm(_ _)m