縄手@松江です.

On Tue, 1 Feb 2005 02:01:19 +0900
Masao Mutoh <mutoh / highway.ne.jp> wrote:

> むとうです。

> ええっと、ruby-gnomeをインストールされたのなら、
> 今までのスクリプトがそのまま動くと思いますが...。
> ruby-gnome2のことでしょうか?

説明が足らなくてすみませんでした.おっしゃる通り,ruby-gnome2です.

Vineのパッケージの都合なんでしょうが,ruby-gtkとruby-gnomeはruby-1.6
のライブラリを必要としていて,Vineにデフォルトのruby-1.8に合わせてapt
でインストールしようとすると,当然ですがruby-gtk2とruby-gnome2が入ります.

> ruby-gtk/ruby-gtk2では細々した点で結構互換性がないです。
> また、GTK+-2.0の段階でDeprecatedになってしまったクラスは
> そもそも実装していません(Gtk::CList, Gtk::CTreeなど)。

Gtk::WINDOW_TOPLEVELとかでいきなり引っかかりました.

> まずは、require 'gtk2'の次に
> 
> Gtk.init
> 
> という行を入れて、その後は出てくるエラーに従って
> 似たようなメソッドをrbbrなどを使って探していくと良いかと
> 思います。

はい,地道に見て行きます.お騒がせしました.

-- 
縄手雅彦@島根大学総合理工学部 電子制御システム工学科
{freedom,justice}@mag.shimane-u.ac.jp
http://www.ecs.shimane-u.ac.jp/~nawate/