けいじゅ@いしつかです.

In [ruby-list:40502] the message: "[ruby-list:40502] Re: getopt", on
Jan/09 06:23(JST) Yukihiro Matsumoto writes:

>まつもと ゆきひろです

>|emperor% ruby -e "require 'getopts'"
>|Warning:-e:1: getopts is deprecated after Ruby 1.8.1; use optparse instead
>|getopts.rb は非推奨品になったということでしょうか? 
>
>そういうことです。

了解です.

過去にそう言う議論てありました? ruby関連のメイリングリストの過去を調べ
たのですが, 探し出せませんでした.

>とはいえ、グローバル変数を多用したgetoptsを今さら推奨するっ
>てのもねえ。

それもそうですね. 

>|あと, getoptlong.rb もあると思いますが, それも推薦品ではないってことで
>|しょうか?
>そうですね。どっちかといえばoptparseを勧めたいって感じです。

そうなんだ.
最近はオプション解析にライブラリを使うときはgetoptlongを使っていたので...

In [ruby-list:40503] the message: "[ruby-list:40503] Re: getopt", on
Jan/09 10:25(JST) nobu / ruby-lang.org writes:

>なかだです。

>> とはいえ, optparse って随分インターフェイスが変わっていて戸惑ってしま
>> うのですが...
>
>getoptsからの移行には、roptがいいんではないでしょうか。
><http://raa.ruby-lang.org/list.rhtml?ropt>

どもです.
でも, optparseも難しい使い方をしなければ, それほど難しくもないようなの
で取りあえずoptparseで行くことにしました.


__
---------------------------------------------------->> 石塚 圭樹 <<---
---------------------------------->> e-mail: keiju / ishitsuka.com <<---